消息关闭
    暂无新消息!

更新了gem后怎么输入都是这个错误

问题作者 : Dunster2017-05-05发布

chenfengdeMacBook-Pro:~ chenfeng$ gem install cocoapods
/Users/chenfeng/.rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:17:in `require': cannot load such file -- stringio (LoadError)

from /Users/chenfeng/.rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:17:in `<top (required)>'
from /Users/chenfeng/.rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems.rb:1333:in `require'
from /Users/chenfeng/.rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems.rb:1333:in `<module:Gem>'
from /Users/chenfeng/.rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems.rb:116:in `<top (required)>'
from <internal:gem_prelude>:1:in `require'
from <internal:gem_prelude>:1:in `<compiled>'

求大神指点


2个回答

︿ 0

应该是源的问题,使用官方源的请检查梯子工作是否正常,不然还是换成 ruby-china 的源吧